Avatar de l’utilisateur
3HeadedMonkey
Tasse
Messages : 268
Enregistré le : 26 Sep 2016, 15:44
Localisation : Montpellier
Contact : Site Internet Facebook Google+ Twitter YouTube

Problème d'ombre sur textures répétées

31 Mai 2017, 13:06

Salut à tous,

je me retrouve confronté à un problème sur un rendu, mais je n'ai aucune idée de comment dénommer la chose sur google :)

Je fais un rendu d'une scène, tout se passe bien sauf le mur en fond, qui se découpe en carré. Ca n'a pas l'air d'être les carrés de répétitions de textures, mais ceux des bucket de rendu. De plus il y a une partie qui est en texture procédurale.

Voici ce que ça donne :

Probleme bucket.png


Vous avez une idée d'où ça pourrait venir ?

Merci d'avance !
0
" L'ouverture d'esprit ne se limite pas à une simple fracture du crâne ! "

Avatar de l’utilisateur
Nael
Tasse
Messages : 289
Enregistré le : 12 Sep 2015, 21:04

Re: Problème d'ombre sur textures répétées

31 Mai 2017, 14:19

étrange, pas le souvenir d'avoir jamais eu un truc semblable.
ça pourrais être utile d'avoir le projet de la scène pour essayer de comprendre.
0

Avatar de l’utilisateur
3HeadedMonkey
Tasse
Messages : 268
Enregistré le : 26 Sep 2016, 15:44
Localisation : Montpellier
Contact : Site Internet Facebook Google+ Twitter YouTube

Re: Problème d'ombre sur textures répétées

31 Mai 2017, 14:28

J'ai réussi à l'enlever, je ne sais pas si ça vient du fait que j'ai vidé le cache de l'occlusion ambiante, ou bien si j'ai mis le filtre anti-aliasing en Mitchell. Par contre l'IG est plutôt bonne sur toute la scène, sauf sur ce mur.

Truc bizarre aussi, je vide la cache de l'IG, puisque j'ai changé le setup, et ça ne recalcule pas d'IG :/

Aussi, si tu veux voir je peux t'envoyer le projet en MP :)
0
" L'ouverture d'esprit ne se limite pas à une simple fracture du crâne ! "

Avatar de l’utilisateur
3HeadedMonkey
Tasse
Messages : 268
Enregistré le : 26 Sep 2016, 15:44
Localisation : Montpellier
Contact : Site Internet Facebook Google+ Twitter YouTube

Re: Problème d'ombre sur textures répétées

31 Mai 2017, 16:04

Bon bah C4D j'y comprends décidément plus rien. J'ai tout augmenté (détail du rendu physique, meilleur anti aliasing, plus d'échantillon d'IG, j'ai fait un rendu en bossant sur AFX + Photoshop + illustrator en même temps contrairement à la 1ère, et y'a plus le bug, et c'est plus beau, et ça se calcule plus rapidement...

Vraiment, je comprends pas, mais c'est cool :)
1
" L'ouverture d'esprit ne se limite pas à une simple fracture du crâne ! "

Avatar de l’utilisateur
Nael
Tasse
Messages : 289
Enregistré le : 12 Sep 2015, 21:04

Re: Problème d'ombre sur textures répétées

31 Mai 2017, 16:35

J'avoue que j'ai pas trop répondu quand tu a abordé l'IG, ça fait quelques temps que j'utilise plus le rendu physique mais octane ou Cycles parce que l'IG est bien trop longue à calculer.
0

Avatar de l’utilisateur
3HeadedMonkey
Tasse
Messages : 268
Enregistré le : 26 Sep 2016, 15:44
Localisation : Montpellier
Contact : Site Internet Facebook Google+ Twitter YouTube

Re: Problème d'ombre sur textures répétées

31 Mai 2017, 16:43

Ouais faudrait vraiment que je me mette à Octane... C'est juste qu'il y a ce petit clic dans ma tête qui me dit : maîtrise d'abord le truc de base, de tout bien comprendre avant de passer à un truc "plus simple". C'est pour bien acquérir les bases.
0
" L'ouverture d'esprit ne se limite pas à une simple fracture du crâne ! "

Viclio
Gobelet
Messages : 144
Enregistré le : 13 Juin 2017, 15:12

Re: Problème d'ombre sur textures répétées

13 Juin 2017, 19:01

J'ai déjà eu ça aussi, un jour... Et pareil, en vidant tous les caches c'est parti comme par magie.
Parfois ça aide de redémarrer C4D quand on touche beaucoup aux caches de GI et AO, ça ressemble très fortement à un bug et ça traîne depuis un moment. Par curiosité, sur Mac ou PC ?
0

Avatar de l’utilisateur
3HeadedMonkey
Tasse
Messages : 268
Enregistré le : 26 Sep 2016, 15:44
Localisation : Montpellier
Contact : Site Internet Facebook Google+ Twitter YouTube

Re: Problème d'ombre sur textures répétées

14 Juin 2017, 10:17

C'est sur PC. J'avais changé le nom du cache, au cas ou je voulais revenir sur le réglage en arrière. Peut être ça aussi. Mais je ne me souviens plus si j'avais décoché le chargement automatique (normalement oui).

Au final, il y a des choses pour lesquelles je suis content, et d'autres bifbof. Le fourmillement, le flickering font parti des choses que je n'aime pas trop. je trouve que ça manque d'impact graphique aussi, mais c'est sorti du contexte (faudra voir le final en espérant que ça pète). Et il y a la grande roue à l'arrière qui prédomine trop, et pour laquelle je n'avais plus trop d'idées, et les planches ou j'aurais aimé utilisé un peu plus l'effet déplacement mais qui faisait péter des records niveau temps de rendu. Il y a aussi les néons, qui ont de l'OA (pas logique) et je n'arrivais pas trop à régler l'effet lueur.

Après je suis content de quelques textures, et surtout de la facilité d'appliquer comme je les voulais, et pour la modélisation ou je n'ai pas trop galérer (en même temps ça reste du simple).

phpBB [video]
1
" L'ouverture d'esprit ne se limite pas à une simple fracture du crâne ! "

Viclio
Gobelet
Messages : 144
Enregistré le : 13 Juin 2017, 15:12

Re: Problème d'ombre sur textures répétées

14 Juin 2017, 11:41

Le fourmillement sur le mur est bizarre, en effet, il ne devrait pas y en avoir sur ce genre de scène. Sur le tapis pas exemple, comment as tu réglé ta texture ? C'est une bitmap ? Si oui tu peux essayer d'autres échantillloneurs (SAT par exemple) qui permettent de limiter ce genre d'effet surtout en augmentant l'échelle de flou.
Sur le mur, ça ressemble tout simplement à des problème d'anti-aliasing. Tu es en Physical ou Standard ? Le Physical marche mieux dans ce genre de scène à l'éclairage réaliste. C'est peut être aussi le bump qui est réglé trop fort tout simplement, ça marche en image fixe mais en animation ça grésille.
Pour le plancher, le bump en parallaxe introduit avec la R18 marche vraiment super bien.
Sinon, le mieux est de modéliser tes planches (avec Mograph, ça va vite). En effet le displacement est super lourd et ne marche pas si bien pour du plancher.

Sinon, tu es dur avec toi même, elle est bien ta scène, bien composée. Comme tu dis, dans son contexte en plus ça doit forcément mieux passer.
Même le fourmillement, il faut quand même le remarquer. Personnellement je pardonne très volontiers ce genre de défaut technique tant que le cadre est bien composé et qu'il y a une cohérence graphique.
0

Avatar de l’utilisateur
3HeadedMonkey
Tasse
Messages : 268
Enregistré le : 26 Sep 2016, 15:44
Localisation : Montpellier
Contact : Site Internet Facebook Google+ Twitter YouTube

Re: Problème d'ombre sur textures répétées

14 Juin 2017, 12:44

J'ai utilisé du bump avec du bruit, pour les murs, (2%) et je les ai appliqué en planaire (peut être ça le problème).
Pour le tapis j'ai utilisé simplement une réflexion en type Irawan (le tissu). Je n'ai rien rajouté d'autres.

Je suis en Physical, mais je ne me suis pas trop penché dessus (pas vu beaucoup de tuto sur le rendu physique). Du coup j'ai mis en échantillonage fixe avec une sub de l'échantillonnage à 5, un raytrace embrée (j'osais pas toucher), et un filtre Mitchell pour l'AA.

Pour le plancher j'ai utilisé Mograph, avec variation etc... mais les planches paraissaient trop plates, et avec le déplacement ça donnait plus de variations pour donner des creux dans les planches, beaucoup plus propre que le bump.

Et merci pour les encouragements, de toute façon, je suis jamais content de mon taf, et quand je regarde 3-4 mois après je fais : ah ouais, c'était cool en fait. Mais c'est ce qui me fais avancer ;)
0
" L'ouverture d'esprit ne se limite pas à une simple fracture du crâne ! "

Retourner vers « Rendu »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 1 invité