ben_motion
Gobelet
Messages : 203
Enregistré le : 22 Aoû 2016, 21:47
Localisation : Montpellier
Contact : Site Internet Facebook

Temps de rendu aléatoires ou exponentiels

06 Sep 2016, 09:29

Salut tout le monde,

depuis quelques temps j'ai de petit soucis avec After au niveau des rendus et j'aurai voulu savoir si vous aviez rencontrés les mêmes problèmes.
Exemple hier : Projet After assez simple, un Ipad dans Element, anime d'interface, quelques lumières, ombres, profondeur de champs, ect… C'est un projet type que je suis sensé maitriser assez bien ( et surtout maitriser la charge machine ). La comp est assez équivalente du début à la fin ( je n'ai pas de moment qui chargerait le rendu, comme des particules ou d'autres effets ). Et là arrive le rendu…

Premier rendu : After rend la moitié de la comp en 30 min, ce qui me parait cohérent ( je suis sensé faire 1min en 1 heure sur ce type de projet ), puis arrive au 3/4 en 1h30, puis m'annonce qu'il reste 1 heure et semble ralentir. J'arrête le rendu ( à peu près aux 3/4 de la comp ), je relance la partie restante qui se boucle en 12 minutes

Du coup je me dis que je vais tester un deuxième rendu : Après 9h20 de rendu il avait fait 80% de la comp. J'ai arrêté et relancer, il a bouclé la fin en 5 minutes…

Sur d'autres projets ( je n'ai pas d'exemple précis ), j'ai des différences de temps de rendus sur les même comp qui vont du simple au triple sans raison apparente ( genre je n'ai pas d'autres rendus en cours ). Les problèmes se règlent souvent en quittant et en relançant After…

Je n'ai pas l'impression que ce soit un soucis de mémoire ( ça fait longtemps que je n'ai pas entendu la chèvre d'ailleurs ) et tout semble bon dans mon menu "secret"…

Bref, je ne cherche pas forcément de solution mais juste savoir si je suis le seul ou pas ( ça pourrait être un soucis qui vient plus de mon système que d'After après tout )

A+
Ben
0

Avatar de l’utilisateur
Nikko
Tasse
Messages : 336
Enregistré le : 06 Sep 2015, 03:43

Re: Temps de rendu aléatoires ou exponentiels

06 Sep 2016, 10:28

C'est chelou ça, je crois pas que ça m'ait arrivé, aubonbeurre devrait avoir une meilleure idée de ce qui se passe...

T'as essayé d'ouvrir le projet sur une autre machine? Faudra peut être réinstaller AE. Essayer de désactiver certaines parties de ta comp histoire de voir s'il y a un layer qui déconne, etc... PAr exemple, j'essaierai de faire le rendu sans Element (même si ta comp n'a que ça).

J'y pense ce serait pas éventuellement un problème de disque dur?
0

ben_motion
Gobelet
Messages : 203
Enregistré le : 22 Aoû 2016, 21:47
Localisation : Montpellier
Contact : Site Internet Facebook

Re: Temps de rendu aléatoires ou exponentiels

06 Sep 2016, 11:18

J'ai pas essayé de lancer le projet sur une autre machine, d'autant que ça ne vise pas un projet particulier ou même Element, même si c'est vrai que ce sont principalement des projets avec Element qui ont ce soucis, mais pas que... Je pensais à une faiblesse de la carte graphique mais je serai sensé avoir des soucis dans d'autres appli…

Après la piste du disque dur est peut-être à tester, déjà parce qu'il est vieux, et puis parce que parfois After met 5 fois plus de temps à enregistrer un projet ( que la fois d'avant, qui était 5 minutes plus tôt en règle général ). Mais en même temps, si je quitte le soft et que je le ré-ouvre, tout reprend une vitesse normale…
0

Avatar de l’utilisateur
Duduf
Mug
Messages : 601
Enregistré le : 16 Juin 2015, 18:02
Contact : Site Internet

Re: Temps de rendu aléatoires ou exponentiels

06 Sep 2016, 16:27

Ça ressemble à un problème de mémoire cache ça ; si fermer/rouvrir redonne de la performance, je pencherai pour dire que ya des trucs qui squattent la mémoire, et du coup qui finissent par tout remplir et ralentir le rendu ; et ce serait vidé quand AE est rebooté.


Un classique des rendus en 3D comme problème. Ca m'est arrivé souvent de scripter un truc qui lance le rendu des frames par batch d'une dizaine au lieu de toute une timeline d'un coup, mais je n'avais jamais remarqué ça sur AE
0

ben_motion
Gobelet
Messages : 203
Enregistré le : 22 Aoû 2016, 21:47
Localisation : Montpellier
Contact : Site Internet Facebook

Re: Temps de rendu aléatoires ou exponentiels

06 Sep 2016, 18:19

Duduf a écrit :Ça ressemble à un problème de mémoire cache ça ;


Merci DufDuf, ça peut être effectivement une piste. Il faudra que je fasse un test en vidant le cahce d'After toutes les 50 ou 100 images pour voir si ça règle le problème.

Duduf a écrit :mais je n'avais jamais remarqué ça sur AE


Ha ha, t'as jamais bossé avec la suite Final Effect ou Boris Continuum ( sur de vieilles versions ) :-) C'était pas rare d'avoir un rendu qui marchait très bien jusqu'à ce que ça bloque et qu'on entende la fameuse chèvre d'After ( et ça plantait toute la file de rendu, tant qu'à faire… )

A+
Ben
1

ben_motion
Gobelet
Messages : 203
Enregistré le : 22 Aoû 2016, 21:47
Localisation : Montpellier
Contact : Site Internet Facebook

Re: Temps de rendu aléatoires ou exponentiels

09 Sep 2016, 09:20

Bon, suite de mes pérégrinations. En allant dans le menu "secret" d'After, je me suis rendu compte que j'avais déjà un réglage qui vidait le cache toutes les 30 images, du coup c'est pas ça…

Sauf que : quand j'utilise Element et que je fais un rendu, d'habitude j'ai beaucoup de mal à utiliser mon ordi car Element bouffe toutes les ressources de la carte graphique. Et c'est bien ce qu'il se produit en début de rendu mais plus on avance, moins After prend de la puissance sur l'ordi ( d'ailleurs en fin de rendu les ventilos tournent clairement moins vite qu'au début ). Du coup je penche pour un soucis du système, genre ma carte graphique qui se met en mode ralenti au bout d'un moment. Bref, vivement que je change de machine :-)

Sinon sur mon dernier rendu After a décidé de me planter le son. Le début de la ma vidéo commence avec le son qui se trouve au 2/3 de ma comp, continue jusqu'à la fin ( donc à 1/3 de ma vidéo j'ai la fin de ma musique ) et recommence depuis le début… Est-ce que c'est un signe que ma machine veut prendre sa retraite après 3 ans et demi de rendus presque toutes les nuits ? :-)

A+
Ben
0

Avatar de l’utilisateur
Nico Palmier
Gobelet
Messages : 129
Enregistré le : 16 Juin 2016, 09:23
Localisation : France
Contact : Site Internet

Re: Temps de rendu aléatoires ou exponentiels

09 Sep 2016, 09:54

C'est quoi le menu secret ?
0

Avatar de l’utilisateur
Jissse
Modérateur
Messages : 620
Enregistré le : 12 Juil 2015, 13:27

Re: Temps de rendu aléatoires ou exponentiels

09 Sep 2016, 10:04

Des options cachées en plus, faut rester appuyé sur shift en allant dans les préférences générales pour l'ouvrir.
C'est quoi ta cg Ben ? Peut-être qu'elle se fait vieille en effet !
0

ben_motion
Gobelet
Messages : 203
Enregistré le : 22 Aoû 2016, 21:47
Localisation : Montpellier
Contact : Site Internet Facebook

Re: Temps de rendu aléatoires ou exponentiels

09 Sep 2016, 10:07

Non mais vous allez me jeter des cailloux :-) Déjà je bosse sur mac….portable….de 2012…. Et donc ma carte graphique est une fabuleuse Geforce 650m avec 1Go de Ram ( enfin c'est la théorie car Element n'en voit que 384Mo ). Après c'est pas faute de vouloir changer de machine…
0

Avatar de l’utilisateur
Jissse
Modérateur
Messages : 620
Enregistré le : 12 Juil 2015, 13:27

Re: Temps de rendu aléatoires ou exponentiels

09 Sep 2016, 10:18

Ah ben oui ça me paraît "normal" du coup, j'avais à peu près le même comportement sur mon vieux portable avec une Ati5650... En général je découpais mes comps pour faire mes rendus en plusieurs fois et je remontais tout ça ensuite.
0

Retourner vers « Rendus »

Qui est en ligne

Utilisateurs parcourant ce forum : Aucun utilisateur enregistré et 2 invités